Login | Register
My pages Projects Community openCollabNet

propel
Reply to message

* = Required fields
* Subject
* Body
Attachments
Send reply to
Topic
Author (directly in email)
Please type the letters in the image above.

Original message

Author Pedram Nimreezi <zenstyle@gmail.com>
Full name Pedram Nimreezi <zenstyle@gmail.com>
Date 2006-10-02 05:20:03 PDT
Message WebsiteContact is being referenced by one of your
<foreign tags in one of your *.xml schemas...

I may be wrong but I don't believe I am, hope that helps...



On 10/1/06, Robert Bruce <rob at tdd dot org dot uk> wrote:
> I have a system whereby I use a multi-component setup with propel, using
> multiple schema files. Everything works fine for code generation and
> installing the sql, however when I come to run a datadump an error
> occurs regarding a missing table. The table does exist in the database,
> but I believe the error is due to the schema files not been processed in
> dependency order.
>
> Here is an output from attempting to run the datadump target
>
> http://www.tdd.org.u​k:81/propel.txt
>
> If you look at the order the schema files are processed the first file
> licencing.schema.xml depends on the schema website.schema.xml which is
> being processed further down the list. Is there any way can control the
> order in which the schema files are processed? Or is there any other way
> to get around this problem?
>
> --------------------​--------------------​--------------------​---------
> To unsubscribe, e-mail: dev-unsubscribe@prop​el.tigris.org
> For additional commands, e-mail: dev-help at propel dot tigris dot org
>
>


--
~
Pedram Nimreezi -- President/Senior Engineer
Major Computing, Inc
--

Not by age, but by knowledge is wisdom acquired.