Login | Register
My pages Projects Community openCollabNet

Discussions > dev > What's the minimum php version for propel-1.3?

propel
Discussion topic

Back to topic list

What's the minimum php version for propel-1.3?

Reply

Author andre_c
Full name Alvaro Carrasco
Date 2007-03-10 23:09:19 PST
Message Hi,
I noticed that propel 1.3 is producing a base object that requires the
DateTime class, which is not available on my php 5.1.6, causing a fatal
error:

...
    234 * @param DateTime $v new value
    235 * @return void
    236 */
    237 public function setStartDate($v)
    238 {
    239
    240 if ($v !== null && !($v instanceof DateTime)) {
    241 try {
    242 if (is_numeric($v)) { // if it's a unix timestamp
...

what is the minimum php version for propel?
the docs on the wiki say 5.0 but they're probably out of date.
is this a bug? :-o

Alvaro

« Previous message in topic | 1 of 4 | Next message in topic »

Messages

Show all messages in topic

What's the minimum php version for propel-1.3? andre_c Alvaro Carrasco 2007-03-10 23:09:19 PST
     Re: [propel-dev] What's the minimum php version for propel-1.3? andre_c Alvaro Carrasco 2007-03-10 23:14:22 PST
         Re: [propel-dev] What's the minimum php version for propel-1.3? hlellelid Hans Lellelid 2007-03-11 06:18:26 PDT
             Re: [propel-dev] What's the minimum php version for propel-1.3? Cameron Brunner <cameron dot brunner at gmail dot com> Cameron Brunner <cameron dot brunner at gmail dot com> 2007-03-11 15:44:39 PDT
Messages per page: